User management in NA21 is currently unavailable
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 17:14 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 28, 2024 - 17:10 UTC
Investigating
We are currently investigating this issue.
Posted Mar 28, 2024 - 16:52 UTC
This incident affected: CLM (NA21).