Customers may experience latency when sending and signing (Incident 4392)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Feb 24, 2026 - 11:59 UTC

Investigating

We are currently investigating the issue.
Posted Feb 24, 2026 - 10:04 UTC
This incident affected: eSignature (DEMO).