Notification failures when utilising Outlook (Incident 5087)

Incident Report for Docusign

Resolved

We can confirm that this issue is now resolved, thank you for your patience.
Posted Jun 12, 2026 - 06:37 UTC

Monitoring

A fix has been applied and our engineering teams are actively reviewing our telemetry to confirm this fix has mitigated the issue.
Posted Jun 12, 2026 - 06:10 UTC

Investigating

Customers utilising Outlook may receive delivery notification failures when sending envelopes to signers. Engineering teams have been engaged and we are actively triaiging this issue.
Posted Jun 12, 2026 - 06:04 UTC
This incident affected: eSignature (AU, CA, EU, JP1, NA1, NA2, NA3, NA4).