Some customers may experience latencies sending and signing in EU (Incident-4915)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted May 19, 2026 - 14:36 UTC

Update

We are continuing to investigate the issue.
Posted May 19, 2026 - 13:30 UTC

Investigating

We are currently investigating the issue.
Posted May 19, 2026 - 12:59 UTC
This incident affected: eSignature (EU).