CLM Prod NA11 Customers are experiencing issues accessing their accounts and performing actions (Incident 4348)

Incident Report for Docusign

Resolved

This incident has been resolved.

Some customers may have experienced errors or delays with login, browsing, generating, or previewing documents from 2026-02-15 07:47 PM UTC until 2026-02-15 09:57 PM UTC.
Posted Feb 15, 2026 - 21:56 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 15, 2026 - 21:45 UTC

Investigating

We are currently investigating this issue.
Posted Feb 15, 2026 - 20:50 UTC
This incident affected: CLM (NA11).