Some customers may not be able to access the site - IM-39587
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Mar 12, 2024 - 23:45 UTC
Identified
The issue has been identified. An update will be provided when we receive a response from our provider.
Posted Mar 12, 2024 - 19:44 UTC
Update
We are continuing to investigate this issue.
Posted Mar 12, 2024 - 19:33 UTC
Investigating
We are currently investigating this issue.
Posted Mar 12, 2024 - 18:54 UTC
This incident affected: CLM (US13) and eSignature (USFED).