Organization Reports May Remain in "Exporting" Status (Incident 5020)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

For any organization reports that were stuck during this incident if it was a scheduled report the user could re-create one and if it was an export now they could re-run it.

Customers may have experienced errors from 2026-06-03 05:00 AM UTC until 2026-06-04 10:50 AM UTC.
Posted Jun 04, 2026 - 12:00 UTC

Update

We are continuing to work on a fix for the issue.
Posted Jun 04, 2026 - 09:07 UTC

Identified

Customers may be experiencing issues when attempting to export organization reports. Our engineering teams are engaged and have identified the cause and are working on a fix for this.
Posted Jun 04, 2026 - 06:58 UTC
This incident affected: eSignature (AU, CA, EU, FedRAMP, NA1, NA2, NA3, NA4, DEMO).