Some users might experience latency when attempting to convert non-PDF documents (Incident-4750)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced latency from 2026-04-23 02:53 PM UTC until 2026-04-23 08:09 PM UTC
Posted Apr 23, 2026 - 23:18 UTC

Update

We continue to monitor for stability while we investigate possible secondary factors.
Posted Apr 23, 2026 - 22:34 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2026 - 21:23 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 23, 2026 - 20:02 UTC

Update

We continue to monitor the environment to ensure stability.
Posted Apr 23, 2026 - 19:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 17:31 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 23, 2026 - 17:07 UTC

Investigating

We are currently investigating this issue.
Posted Apr 23, 2026 - 16:28 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU).