NA4 PROD eSign: Users may experience latency or errors when navigating the site (DIRCA-4154)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jan 20, 2026 - 18:00 UTC

Update

We are continuing to investigate this issue.
Posted Jan 20, 2026 - 17:47 UTC

Update

We are continuing to investigate this issue.
Posted Jan 20, 2026 - 17:43 UTC

Investigating

Users may experience throttling errors and/or rejected requests on their accounts.
Posted Jan 20, 2026 - 17:00 UTC
This incident affected: eSignature (NA4).