Login failures and Latency Issues with Sending and Signing Envelopes (Incident 4717)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced login failures and latency issues with Sending and Signing from 2026-04-17 02:08 PM UTC until 2026-04-17 03:09 PM UTC
Posted Apr 17, 2026 - 16:18 UTC

Update

We are continuing to monitor for any further issues.
Posted Apr 17, 2026 - 15:57 UTC

Monitoring

Internal testing is showing the implemented fix has resolved the impact, we are continuing to monitor to ensure the issue is fully mitigated.
Posted Apr 17, 2026 - 15:12 UTC

Identified

Our engineering teams have identified the root cause of this issue and are in the process of deploying a fix.
Posted Apr 17, 2026 - 14:53 UTC

Investigating

We are currently investigating a spike in latency for send and sign services which may affect a subset of customers. We have engaged our engineering teams and are actively triaging this issue.
Posted Apr 17, 2026 - 14:47 UTC
This incident affected: eSignature (CA).