NA21 CLM: Some customers may experience high latency and/or failures related to core features which include browsing folders, previewing documents, uploading or downloading documents, generating documents or executing workflows

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced latency from 2025-10-23 10:36 PM UTC to 2025-10-23 11:00 PM UTC.
Posted Oct 23, 2025 - 23:20 UTC

Investigating

We are currently investigating this issue.
Posted Oct 23, 2025 - 23:01 UTC
This incident affected: CLM (NA21).