Search Indexing Delays (Incident 4539)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Mar 18, 2026 - 08:22 UTC

Identified

As a continuation of incident 4517, a subset of customers may experience incomplete search results for historical documents older than one year. A fix is currently underway, and full resolution is anticipated by Wednesday, March 18, 2026 at 11:00 AM UTC.
Posted Mar 18, 2026 - 00:13 UTC
This incident affected: CLM (EU21).