Some customers may not able to open any CLM documents (Incident 5375)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jul 13, 2026 - 20:19 UTC

Identified

We have identified the issue and a fix is being implemented.
Posted Jul 13, 2026 - 19:55 UTC
This incident affected: CLM (EU11, EU21).