Workflow Reports Experiencing Timeout Errors (Incident 4874)

Incident Report for Docusign

Resolved

This incident has now been resolved.
Posted May 13, 2026 - 14:18 UTC

Monitoring

A fix has been implemented and we are observing telemetry to validate.
Posted May 13, 2026 - 13:41 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 13, 2026 - 11:50 UTC

Identified

Customers may be experiencing timeout errors with Workflow and Document Reports. Engineering teams have been engaged and the issue has been identified, a fix is currently being implemented.
Posted May 13, 2026 - 11:49 UTC
This incident affected: CLM (EU11, EU21).