Users may experience errors or timeouts when navigating the site
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Mar 11, 2024 - 21:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2024 - 20:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2024 - 20:22 UTC
Investigating
We are currently investigating this issue.
Posted Mar 11, 2024 - 20:04 UTC
This incident affected: CLM (NA11, NA21, EU11, EU21).