AU PROD eSign: Users may experience latency or errors when navigating the site (DIRCA-2611)

Incident Report for Docusign

Postmortem

RCA for AU eSign Service Disruption on May 14, 2025

Impact Summary:

From  May 14, 2025 10:00 PM UTC to May 15, 2025 01:31 AM UTC, customers may have experienced errors or increased latency across the eSignature service based out of the AU site.

Some users may have experienced intermittent latency or errors when attempting to login, sign or send documents for signature.

Cause:

The disruption inadvertently occurred as a result of a planned service migration.  During the impacted window, some servers were unable to connect to a database due to a configuration issue.  This generated latency and errors for customers.

Resolution:

To restore services for customers, the impacting configuration change was rolled back. To better detect and more quickly address this type of failure in the future:

  • We are updating our internal procedures to perform additional validation testing to help ensure connections to databases are stable.
  • We are assessing refinements to our failure timeout periods to further enhance system resiliency.
Posted May 19, 2025 - 20:51 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted May 15, 2025 - 01:49 UTC

Monitoring

We have applied a change and are seeing some improvements. We continue to monitor system health.
Posted May 15, 2025 - 01:37 UTC

Update

We continue to actively work on improving site performance. Users may be experiencing latency or errors when attempting to navigate the site.
Posted May 15, 2025 - 01:12 UTC

Identified

We have identified the cause of the issue and and working on restoring service. We are seeing some improvement, although customers may still experience latency or errors.
Posted May 15, 2025 - 00:37 UTC

Update

We continue to actively investigate this incident and devise a plan to restore service.
Posted May 15, 2025 - 00:27 UTC

Investigating

We are currently investigating this issue.
Posted May 14, 2025 - 23:57 UTC
This incident affected: eSignature (AU).