Failures with Envelope Writeback and Status Updates (Incident 5505)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation. Customers may have experienced errors from 2026-07-29 01:43 AM UTC until 2026-07-31 05:14 PM UTC.
Posted Jul 31, 2026 - 18:01 UTC

Update

The issue has been identified and we continue our work to implement a fix.
Posted Jul 31, 2026 - 17:51 UTC

Identified

We have identified the issue and a fix is being implemented.
Posted Jul 31, 2026 - 17:33 UTC

Update

We are currently investigating an issue affecting customers using the Salesforce integration across EU and NA regions. Customers may experience failures with envelope write-back and status updates, with the error: "The underlying connection was closed. An unexpected error occurred on send."

Services affected: Salesforce connector (envelope write-back, status updates)
Impact: Completed envelope statuses may not be reflected in Salesforce.

Our engineering teams are actively investigating the root cause across multiple workstreams. We will provide updates as the investigation progresses.
Posted Jul 31, 2026 - 17:16 UTC

Update

We continue to investigate the issue and additional resources have been engaged.
Posted Jul 31, 2026 - 15:23 UTC

Update

We are continuing to investigate this issue.
Posted Jul 31, 2026 - 15:22 UTC

Investigating

Customers in Europe may experience failures with envelope writeback and status update when reviewing Connect logs for DAL envelopes. Engineering teams are engaged and are actively triaging.
Posted Jul 31, 2026 - 12:45 UTC
This incident affected: eSignature (EU, NA2, NA3, NA4, DEMO).