Customers may experience issues with Microsoft Power Automate (IM-39654)
Incident Report for DocuSign
Postmortem

RCA for Power Automate Disruption on April 2, 2024

Impact Summary:

Customers using Microsoft Power Automate would have been unable to process envelopes in their accounts during the affected time period.

Cause:

The impact occurred due to an issue with Microsoft Power Automate infrastructure, affecting its normal operation between 3/31 and 4/2.

Resolution:

Microsoft mitigated the issue by updating the access policy on the affected DocuSign connector.

Microsoft is also taking internal steps to prevent future occurrences of this issue.

Posted Apr 06, 2024 - 03:04 UTC

Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Apr 02, 2024 - 21:51 UTC
Monitoring
Microsoft has implemented a fix and we are continuing to monitor with Microsoft.
Posted Apr 02, 2024 - 19:45 UTC
Update
We are continuing to work this issue with Microsoft.
Posted Apr 02, 2024 - 18:32 UTC
Update
We are still investigating the root cause of this issue, we are engaged with Microsoft and working on a solution.
Posted Apr 02, 2024 - 17:54 UTC
Identified
The issue has been identified
Posted Apr 02, 2024 - 17:16 UTC
Investigating
We are currently investigating this issue.
Posted Apr 02, 2024 - 16:40 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU, DEMO).