Customers are unable to perform ID verification for QES. (DIRCA-1819)
Incident Report for Docusign
Resolved
The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers were unable to perform ID verification for QES from 2024-10-21 09:27UTC to 2024-10-21 10:11UTC.
As a workaround users could have used ID Wallet for verification if they had that already configured prior to the incident.
Posted Oct 21, 2024 - 10:28 UTC
Monitoring
The third party IDV provider has implemented a fix. We are monitoring metrics to confirm the issue is fixed.
Posted Oct 21, 2024 - 10:20 UTC
Investigating
This is an issue with a third party IDV provider. The provider are investigating their issue.
As a workaround users can use ID Wallet if they had that already configured prior to the incident.
Posted Oct 21, 2024 - 10:10 UTC
This incident affected: eSignature (EU).