Customers may experience issues accessing and logging into eSign (DIRCA-2840)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jun 24, 2025 - 09:18 UTC

Update

We are continuing to investigate this issue.
Posted Jun 24, 2025 - 08:55 UTC

Investigating

We are currently investigating this issue.
Posted Jun 24, 2025 - 08:55 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU, DEMO, JP).