Delays in Email Notifications (DIRCA-3834)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced delays with receiving email notifications from 2025-11-07 04:00 AM UTC until 2025-11-20 06:30 AM UTC.
Posted Nov 20, 2025 - 18:43 UTC

Investigating

Customers may be experiencing delays with receiving Email notifications, these notifications will eventually process but our engineering teams are currently engaged and are investigating this delay.
Posted Nov 19, 2025 - 23:17 UTC
This incident affected: eSignature (EU).