CLM NA11 Customers may experience latency (DIRCA-4165)

Incident Report for Docusign

Resolved

This incident has been resolved.

Customers may have experienced intermittent latency and delays in tasks such as document preview and document generation from 2026-01-21 04:39 PM UTC until 2026-01-21 07:11 PM UTC.
Posted Jan 21, 2026 - 20:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jan 21, 2026 - 19:17 UTC

Update

We continue to investigate. The latency is intermittent.
Posted Jan 21, 2026 - 18:37 UTC

Update

We are continuing to investigate this issue.
Posted Jan 21, 2026 - 18:09 UTC

Investigating

We are currently investigating this issue.
Posted Jan 21, 2026 - 17:49 UTC
This incident affected: CLM (NA11).