Some CLM NA21 customers may experience errors when attempting to login, load pages, or make API calls (DIRCA-2794)

Incident Report for Docusign

Postmortem

RCA for CLM NA21 Service Disruption on June 16, 2025

Impact Summary:

Some CLM NA21 customers may have been unable to login, perform various document operations, or execute workflow requests from June 16, 2025 01:50 PM UTC to 08:53 PM UTC.

Cause:

As a result of planned SQL database maintenance, an unexpected issue occurred that disrupted data replication that supports login and workflow transactions. The replication state was determined to be unrecoverable without manual intervention.

Resolution:

All maintenance was halted, and data replication was recovered by reducing traffic to the SQL database for the synchronization operation to complete successfully. 

We are reviewing our maintenance procedures to improve validation steps and reduce detection and mitigation time in the future.

Posted Jun 17, 2025 - 18:21 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-06-16 01:50 PM UTC until 2025-06-16 08:53 PM UTC. Customers who experienced failed workflows may have to restart them based on business need.
Posted Jun 16, 2025 - 21:02 UTC

Update

At this point users in NA21 should be able to login and access most CLM functionality. Some users may still experience errors when running workflows. We are continuing to work on resolution of the workflow issue.
Posted Jun 16, 2025 - 19:38 UTC

Monitoring

A fix has been implemented and we are seeing improvements. We will continue to monitor and will update once we are fully resolved.
Posted Jun 16, 2025 - 19:21 UTC

Update

We continue to work on resolving the issue.
Posted Jun 16, 2025 - 17:45 UTC

Identified

The issue has been identified and we are working on resolving the problem.
Posted Jun 16, 2025 - 15:54 UTC

Update

We are continuing to investigate this issue.
Posted Jun 16, 2025 - 15:08 UTC

Investigating

We are currently investigating this issue.
Posted Jun 16, 2025 - 14:37 UTC
This incident affected: CLM (NA21).