NA/EU PROD eSign: Some users may encounter an error when attempting to login (DIRCA-3399)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Sep 12, 2025 - 16:58 UTC

Update

A fix is still in progress, but users should start to see improvements. We will continue to provide updates until we are fully resolved.
Posted Sep 12, 2025 - 16:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 12, 2025 - 15:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 12, 2025 - 15:12 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, EU).