A limited number of customers may experience some latency

Incident Report for Docusign

Resolved

Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted May 25, 2023 - 19:04 UTC

Update

We are continuing to monitor for any further issues.
Posted May 25, 2023 - 18:47 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 25, 2023 - 18:47 UTC
This incident affected: eSignature (NA1, NA4).