Some users may be experiencing issues, including with signing a document.

Incident Report for Docusign

Postmortem

RCA for DocuSign eSignature and Rooms Service Disruption on September 12, 2023

Impact Summary:

DocuSign eSignature and Rooms customers and users may have experienced a disruption on Tuesday, September 12, between 10:56 PDT and 13:20 PDT.

Some signers may have observed errors or an inability to complete interactive signing transactions during the affected time.

Cause:

The root cause was the result of a bug associated with a recent code deployment. Beginning August 18, DocuSign performed a gradual deployment to enhance the application’s end-user experience. On September 12, we discovered a bug that resulted in intermittent throttling by DocuSign’s Content Delivery Network (CDN).

Resolution:

The incident was resolved by executing a failover to alternate DocuSign infrastructure.

Next Steps:

We recommend customers who encounter an error retry any affected transactions. For additional assistance or questions regarding restarting affected transactions, please contact customer support via https://support.docusign.com.

Posted Sep 15, 2023 - 02:10 UTC

Resolved

The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Sep 12, 2023 - 20:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 12, 2023 - 20:11 UTC

Monitoring

The incident has been mitigated and we are monitoring the results.
Posted Sep 12, 2023 - 20:05 UTC

Update

We are still investigating the issue. We believe we have identified the issue and we are working on a fix.
Posted Sep 12, 2023 - 19:50 UTC

Update

We are continuing to investigate this issue. Approximately 20% of users are seeing issues with signing.
Posted Sep 12, 2023 - 19:35 UTC

Investigating

We are currently investigating this issue.
Posted Sep 12, 2023 - 19:18 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU).