Customers Unable to Purchase Plans (Incident 5034)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jun 05, 2026 - 22:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 05, 2026 - 22:22 UTC

Identified

We have identified the issue and a fix is being implemented.
Posted Jun 05, 2026 - 22:15 UTC

Investigating

We are actively investigating this issue.
Posted Jun 05, 2026 - 22:02 UTC