Some users might experience email delivery delays (39857)
Incident Report for Docusign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted May 15, 2024 - 22:18 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 15, 2024 - 21:05 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 15, 2024 - 20:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 15, 2024 - 17:16 UTC
Investigating
We are currently investigating this issue.
Posted May 15, 2024 - 17:00 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, DEMO).