The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Aug 05, 2025 - 23:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 05, 2025 - 22:54 UTC
Update
We have confirmed the issue is resolved in EU Prod environment. We are continuing the deployment in NA Prod.
Posted Aug 05, 2025 - 20:50 UTC
Update
We continue to work on fully resolving the issue. Users should start to notice improvement. To clarify impact, some users may experience intermittent failures of post-signing actions related to agreement actions.
Posted Aug 05, 2025 - 19:15 UTC
Identified
We have identified the cause of the issue and are working on resolving it.
Posted Aug 05, 2025 - 18:49 UTC
Update
We are continuing to investigate this issue.
Posted Aug 05, 2025 - 18:06 UTC
Investigating
We are currently investigating this issue.
Posted Aug 05, 2025 - 17:33 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, EU).