On September 1, this site will be replaced by health.docusign.com/status.
To continue getting notifications, you'll need to resubscribe on the new site.
View detailed instructions here.
The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Aug 12, 2026 - 02:49 UTC
Update
We continue to monitor the environment to ensure stability.
Posted Aug 12, 2026 - 00:16 UTC
Monitoring
We continue to monitor the environment to ensure stability.
Posted Aug 11, 2026 - 21:09 UTC
Update
We continue to work to implement a fix for the issue.
Posted Aug 11, 2026 - 19:49 UTC
Identified
Our initial fix did not fully mitigate this issue. Our teams are continuing to work to implement a fix to resolve the issue.
Posted Aug 11, 2026 - 18:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2026 - 18:17 UTC
Update
The issue has been identified and we continue our work to implement a fix.
Posted Aug 11, 2026 - 17:58 UTC
Identified
We have identified the issue and a fix is being implemented.
Posted Aug 11, 2026 - 17:08 UTC
Update
We continue to investigate the issue and additional resources have been engaged.
Posted Aug 11, 2026 - 16:12 UTC
Update
We are continuing to investigate this issue.
Posted Aug 11, 2026 - 14:42 UTC
Investigating
We are currently investigating issues where some customers may see latency or failures when generating documents. Engineering teams have been engaged and are actively triaging.