Rooms, Workspaces, and all Docusign add-ins available on Microsoft AppSource are currently unavailable due to an Azure outage (DIRCA-3689)

Incident Report for Docusign

Postmortem

RCA for Rooms, Workspaces, and Docusign Microsoft Plugins Service Disruption on October 29, 2025

Impact Summary:

Docusign customers were unable to access Rooms, Workspaces, or Docusign Microsoft plugins between 03:45 PM UTC and 11:42 PM UTC on October 29, 2025

Cause:

Docusign utilizes Microsoft’s Azure Front Door service to provide access to Rooms, Workspaces, and Microsoft plugins. On October 29, an outage impacting Microsoft services affected our ability to serve traffic to some customers. Microsoft has confirmed the issue was caused by an unintended configuration change in Azure, which led to disruptions across multiple services, including Azure Front Door.

Resolution:

Microsoft reverted the update and finished restoring server capacity on October 30 at 00:05 UTC, at which point Docusign customers could again access the Rooms, Workspaces and Microsoft plug-ins.

Further details from Microsoft regarding this issue can be found at https://azure.status.microsoft/status/history/?trackingId=YKYN-BWZ

(Tracking ID: YKYN-BWZ).

Posted Oct 31, 2025 - 03:15 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-10-29 03:45 PM UTC to 2025-10-29 11:42 PM UTC.
Posted Oct 29, 2025 - 21:50 UTC

Update

Rooms and Workspaces are now operating within normal expectations. We are monitoring improved plugin performance
Posted Oct 29, 2025 - 21:11 UTC

Monitoring

As Microsoft improves available capacity, we are starting to see intermittent success for customers utilizing Rooms and Workspaces. Plugins are starting to succeed as well.
Posted Oct 29, 2025 - 20:32 UTC

Update

Microsoft reports they are starting to see recovery on some products, however Rooms, Workspaces, and add-ins remain inaccessible for our customers. Microsoft reports a 2-4 hour window for full recovery. We continue to investigate alternative strategies
Posted Oct 29, 2025 - 19:49 UTC

Update

Microsoft reports some recovery being seen and also continues to work on completing their change roll back
Posted Oct 29, 2025 - 19:15 UTC

Update

Microsoft continues to work on rolling back their changes in the environment
Posted Oct 29, 2025 - 18:39 UTC

Update

Microsoft is working to rollback a change in their environment
Posted Oct 29, 2025 - 17:36 UTC

Update

We are continuing to work with Microsoft
Posted Oct 29, 2025 - 17:10 UTC

Identified

Customers will be unable to access Rooms, Workspaces, and all Docusign add-ins available on Microsoft AppSource due to a Microsoft Azure outage
Posted Oct 29, 2025 - 16:18 UTC
This incident affected: Rooms (DEMO, East US, East US 2).