Severe performance degradation for Customers in NA2

Incident Report for Docusign

Resolved

This incident has been resolved.
Posted May 10, 2023 - 17:07 UTC

Update

Service recovering as of 16:52 UTC
Posted May 10, 2023 - 16:59 UTC

Investigating

We are currently investigating this issue.
Posted May 10, 2023 - 16:35 UTC
This incident affected: eSignature (NA2).