Workflow processing for some North American data center customers is getting stuck and failing to complete. (IM-38937)

Incident Report for Docusign

Postmortem

RCA for DocuSign CLM Service Disruption of its Chicago data center (NA11) on September 21, 2023

Impact Summary:

On September 21, some DocuSign CLM customers may have experienced an interruption in their workflows.  Depending on the workflow design, some workflows may have been completed and others may have timed out in an error state.

Cause:

The root cause was a result of a misconfiguration in a limited number of recently deployed servers which prevented affected CLM workflows from successfully executing.

Resolution:

The new servers were taken offline, and CLM service traffic was redirected to other normally operating servers.

Next Steps:

We recommend customers who encounter an error re-execute any affected workflows.  For additional assistance or questions regarding re-executing affected workflows, please contact customer support via https://support.docusign.com.

Posted Sep 22, 2023 - 23:55 UTC

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 18:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 21, 2023 - 18:09 UTC

Update

We are continuing to investigate this issue.
Posted Sep 21, 2023 - 18:05 UTC

Update

Workflow processing for some North American data center customers is getting stuck and failing to complete.
Posted Sep 21, 2023 - 17:53 UTC

Update

We are continuing to investigate this issue.
Posted Sep 21, 2023 - 17:07 UTC

Investigating

We are currently investigating this issue.
Posted Sep 21, 2023 - 16:29 UTC
This incident affected: CLM (NA11).